Author Topic: RequestAgentLogin error  (Read 158 times)

Offline yves

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
RequestAgentLogin error
« on: December 03, 2018, 04:47:14 PM »
Hi,
we are trying to develop simple desktop voice application and make call directly through T-sever.
We followed the guide in Genesys docs: we succusfully opened t-server protocol, registered address, but we are not able logging in an agent with RequestAgentLogin, the server response is:

'EventError' ('52')
message attributes:
AttributeEventSequenceNumber [long] = 53182369
Time            = ComplexClass(TimeStamp):
   AttributeTimeinuSecs [int] = 842683
   AttributeTimeinSecs [int] = 1543823091
AttributeErrorCode [int] = 58
AttributeErrorMessage [str] = "Out of service"
AttributeThisDN [str] = "........"
AttributeAgentWorkMode [int] = 0 [Unknown]
AttributeThisQueue [str] = "........"
AttributeAgentID [str] = "......."
AttributePassword [str] = [output suppressed]
AttributeReferenceID [int] = 2
AttributeClientID [int] = 12432

What is wrong in our approach?

Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 6759
  • Karma: 56332
Re: RequestAgentLogin error
« Reply #1 on: December 03, 2018, 07:51:07 PM »
Well seems the DN you are trying to log in is just out of service for your PBX. If SIP server is used, remember you need some endpoint that enables that DN first, meaning, an operational phone before doing login.


Enviado de meu E6633 usando o Tapatalk


Offline yves

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
Re: RequestAgentLogin error
« Reply #2 on: December 07, 2018, 08:59:33 PM »
I am now to genesys development so I don't understand, what I have to do.
You are right, SIP server is used.
My steps:
1. TServerProtocol is opened.
2. RequestRegisterAddress

Both steps, are O.K. - it isn't all I need to do? I followed the steps described in Genesys Documentation...


Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 6759
  • Karma: 56332
Re: RequestAgentLogin error
« Reply #3 on: December 07, 2018, 09:28:45 PM »
OK
But the object you are registering to is not alive. Talk you your support platform guys to give you a valid object to monitor. You need to monitor the extension not the agent by the way.


Enviado de meu E6633 usando o Tapatalk