Author Topic: it seems I am blind, cannot find correct WDE option  (Read 376 times)

Offline GregorV

  • Newbie
  • *
  • Posts: 20
  • Karma: 0
it seems I am blind, cannot find correct WDE option
« on: March 11, 2020, 12:25:13 AM »
I am quite sure it must exist, but.....

When starting WDE I want the voice channel logged in and the chat channel should be logged out.

I find lots of options about the state when logged in, but not how to force the login state itself.
The reason why we need it is a licence issue. We have much more agent than chat licenses and want to have different people working on chat every day. If WDE starts up, then for agents who shoud not work with chat that day, the chat channel should not be logged in.

Can someone bring me back on track
Thanks
Gregor

Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 7131
  • Karma: 56330
Re: it seems I am blind, cannot find correct WDE option
« Reply #1 on: March 11, 2020, 12:48:30 AM »
You must check via Roles

Offline GregorV

  • Newbie
  • *
  • Posts: 20
  • Karma: 0
Re: it seems I am blind, cannot find correct WDE option
« Reply #2 on: March 11, 2020, 09:47:11 PM »
Hi cavagnaro,

thanks, but not really, what I am looking for. I suggest you mean the 'Can Use Chat' privilege but that would mean that a supervisor needs to change role assignments nearly every day because the chat channel is not visible in WDE when 'Can Use Chat' in not set to allowed - so the agent cannot login for chat.

We want to enable 500 of our agents for chat. So all 500 agents have the chat channel assigned by privilege.  As we have 100 licenses of course only 100 can login for chat channel (license is only checked out if agent logs in on the channel).

Problem: if the 500 agents start WDE in the mornig the and there is auto-login for chat, we get claims about license error messages after the 101th login. After starting the 500 WDE sessions all should be in login state for voice only. Agents who will work on chat that day should manually login for chat later.

Thanks
Gregor

Offline Kubig

  • Hero Member
  • *****
  • Posts: 2625
  • Karma: 41
Re: it seems I am blind, cannot find correct WDE option
« Reply #3 on: March 11, 2020, 10:07:12 PM »
Just configure the agents to not automatically log into chat channel during agent application startup.
Genesys certified professional consultant (GVP, SIP, GIR and Troubleshooting)

Offline hsujdik

  • Sr. Member
  • ****
  • Posts: 362
  • Karma: 14
    • Genesys Brasil
Re: it seems I am blind, cannot find correct WDE option
« Reply #4 on: March 11, 2020, 10:08:20 PM »
check if the option eservices.disconnect-on-logoff = true suits your needs

https://docs.genesys.com/Documentation/IW/8.5.1/Dep/AgentLoginAndAuthentication#Optimizing_the_Use_of_eServices_Interaction_Server_Licenses

Quote
Specifies whether eServices license use optimization is used or the legacy mode is used.

When the value is set to true, Workspace ensures that:

    The connection to Interaction Server is not opened when no eServices media channel is selected at login time
    The connection to Interaction Server is closed when all eServices media channel are logged off during the session

This does not affect supervisors that have Queue or Team Workbin Management privileges.

This ensures that an eServices seat license is checked out only when a media is logged on by the agent or when a supervisor privilege is granted to the user.

Consequently, when no media are logged on, agents cannot see the content of their workbins.

When the value of this option is set to false (legacy behavior), Workspace connects to Interaction Server and logs the agent on the place as soon as an eServices media privilege is granted to the agent.

Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 7131
  • Karma: 56330
Re: it seems I am blind, cannot find correct WDE option
« Reply #5 on: March 11, 2020, 11:44:41 PM »
How many multimedia seats licenses do you have?

Enviado de meu SM-N9600 usando o Tapatalk


Offline GregorV

  • Newbie
  • *
  • Posts: 20
  • Karma: 0
Re: it seems I am blind, cannot find correct WDE option
« Reply #6 on: March 12, 2020, 12:11:18 AM »
We have100 licenses and want all agents become familiar with chat - this is why these are always different agents.


Offline GregorV

  • Newbie
  • *
  • Posts: 20
  • Karma: 0
Re: it seems I am blind, cannot find correct WDE option
« Reply #7 on: March 12, 2020, 12:20:36 AM »
Hi Kubic,

that exactly is, what I am looking for BUT how ?

Really appreciate a hint, which object, which option to look for.

Thanks
Gregor

Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 7131
  • Karma: 56330
Re: it seems I am blind, cannot find correct WDE option
« Reply #8 on: March 12, 2020, 01:07:27 AM »
Be Careful that if in the role you provide the can use... Will consume a seat license...no matter if the logs in or not


Enviado de meu SM-N9600 usando o Tapatalk


Offline GregorV

  • Newbie
  • *
  • Posts: 20
  • Karma: 0
Re: it seems I am blind, cannot find correct WDE option
« Reply #9 on: March 12, 2020, 05:15:08 AM »
Hi cavagnaro,

are you sure about that ?
We tested WDE with activated chat channel and it looks like the license is only checked out when the agent logs in. I did not find that in the documentation but for the push-preview channel such behaviour is clearly documented - OK, it says that the license is checked out as soon as the agent gets the first pushed preview, but therefore the agent must be logged in. And it is described that the license is checked in as soon as the agent logs out.

Please let me know, if you have different experience with chat channel- that would probably mean that the tested behaviour is not reliable.

Thanks
Gregor



Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 7131
  • Karma: 56330
Re: it seems I am blind, cannot find correct WDE option
« Reply #10 on: March 12, 2020, 01:09:44 PM »
That applies yes for the chat channel, but not for the seat license. Multimedia seats.
Test it so you be sure.

Enviado de meu SM-N9600 usando o Tapatalk