Author Topic: strattribute1-10  (Read 449 times)

Offline Ardim

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
strattribute1-10
« on: April 11, 2021, 02:55:59 AM »
I'd like to search interactions  in UCS for contactId and any (user defined strattributeNN).
The code looks something like this:
        SearchCriteriaCollection scStartAt = SearchCriteriaBuilder.Build(InteractionSearchCriteriaConstants.StartDate,
                                                                                                    Operators.Greater,
                                                                                                    SomeDate);
        RequestGetInteractionsForContact requestGetInteractionsForContact = new RequestGetInteractionsForContact
        {
          ContactId = contact_id,
          EntityTypeId = EntityTypes.Chat,
          SearchCriteria = scStartAt,
          SortCriteria = sortCriteria
        };
But if I add to search any attributes predicate I see error or the same as without attributes predicate result. Did anyone have similar problems and how did they solve them ?

Marked as best answer by Ardim on April 14, 2021, 11:25:51 PM

Offline gen_rtfm

  • Jr. Member
  • **
  • Posts: 89
  • Karma: 1
Re: strattribute1-10
« Reply #1 on: April 13, 2021, 06:16:12 AM »
Hi,

Are the strattributeNN-fields indexed in ucs?

Do you have any examples of errors to share?

Also: do you have same behavior when performing a search (with same search criteria) from a standard genesys application like WDE? if not, the logs from that application are pretty verbose in how it constructs it's request to ucs.

I haven't had any experience with this myself but that's where I'd look.

Br

Skickat från min Mi MIX 3 5G via Tapatalk


Offline Ardim

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
Re: strattribute1-10
« Reply #2 on: April 14, 2021, 02:25:09 PM »
Precisely! And how I didn't think of it right away. Reindexed the entire database forcibly and the problem disappeared. Thank you !  :)