Author Topic: Recursive Update Failure in CME  (Read 3206 times)

Slava

  • Guest
Recursive Update Failure in CME
« on: January 01, 1970, 09:00:00 AM »
Here is a question for you, experts:



At our site we are using configuration server 5.1.510.03. We have over 3000 agents at 3 different locations, and we are using access groups to limit capabilities of different supervisors.



Last night, I have created a new supervisor group access  torontosv, and then I tried to add it to the security propoerty of the tenant. When I did that, it asked me if I want to update the entries recursively, and I have answered yes. CME froze for about 5 minutes, and then told me that there was a database timeout, so none of the securities were updated.  At first I thought that maybe DB is down, but I was able to update securities of an entry one by one.



I tried again, this time monitoring the DB server which is running on a dedicated oracle database server Sun 420 (4 CPUs, 2GBx4 RAM). After I have answered yes to recursive update, CPU utilization went up to 99.9% percent for the oracle process and stayed that way until a CME time out error few minutes later. Usually, CPU is over 90 percent idle.



I figured that this must be due to a huge number of entries in CME, because I was able to update security privileges for smaller entries (Agent groups) , but it still took 30 seconds to complete (100200 entries tops)



Does anyone else have a similar problem? Can it be fixed?



Spasibo  Slava