Author Topic: caller can't hear ringing tone when call is routing and ringing at the agent  (Read 10737 times)

Offline hendro

  • Newbie
  • *
  • Posts: 23
  • Karma: 0
Dear All,

We need help again here,
We have a simple routing strategy that is play announcement using stream manager and routing call to the agent.
The problem is that the caller can't hear ringing tone when call is routing and ringing at the agent side.

Could anybody help us on this issue?

thank you very much in advance,

Best Regards,
Hendro

Offline Fra

  • Hero Member
  • *****
  • Posts: 856
  • Karma: -4
Hi,

do you use SIP server or a switch? what's the value of the URS give_treatment option? 

Fra

Offline hendro

  • Newbie
  • *
  • Posts: 23
  • Karma: 0
Thanks for your response,

yes, we are using genesys sip server 7.5, and the urs give_treatment is false.

thanks,

best regards,
hendro

Offline Fra

  • Hero Member
  • *****
  • Posts: 856
  • Karma: -4
Try to set give_treatment to true or use the ringback function in your IRD strategy.

Fra

Offline hendro

  • Newbie
  • *
  • Posts: 23
  • Karma: 0
Thanks fra,
Sorry for late to reply,

I have tried it with 1 play announcement block, 1 ring tone block, and Select Target Block. And it's working as what we need.
But when I add a play announcement and collect digits block, the ring tone can't work again. Could you advise what I missed here ?

Thank you,
Really appreciate your help

Best Regards,
Hendro

Offline Fra

  • Hero Member
  • *****
  • Posts: 856
  • Karma: -4
Do you mean you have a play&collect block, then a ringback one followed by a target block?

Offline hendro

  • Newbie
  • *
  • Posts: 23
  • Karma: 0
Thanks fra,
sorry for late reply again,

you are right,
I have a play&collect block, then a ringback one followed by a seletion target block.
And I have tried to use music block too, but still cannot work too.

Could you advise what is my problem?

Thank you,

Best Regards,
Hendro

Offline Anitya

  • Newbie
  • *
  • Posts: 10
  • Karma: 0
Hi,

i have the same problem. When the call comes from a Vegastream gateway(H323), i can hear the busy announcements that i have configure, but i can't hear the ringback when the call is routing at the agent. If i call and no announcements are given, to ringback sounds ok.

I think it's a codec problem, because if i make an internal call i can hear the ringback. The configuration of the vegastream hasn't changed, but the URS,TServer,etc were update.

There are some option in the TServer or SM or URS I must change?

Thanks,

Offline Fra

  • Hero Member
  • *****
  • Posts: 856
  • Karma: -4
Hello,

hi to both of you and sorry for my late reply. First of all, which version of SM and URS are you using? Then:
1. does it make any difference if you use a play announcement block followed by a collect digits one rather than a single play&collect?
2. if you are running some tests and you are calling from a sip phone, select only one codec: I had an issue with a 7.5.x SM that let me hear only the very first announcement in the strategy and nothing else that followed it
3. does it make any difference if you select the ringback treatment in the busy tab of the target selection block instead than using the ringback block?

Post URS logs when the ringback play fails.

Fra

Offline hendro

  • Newbie
  • *
  • Posts: 23
  • Karma: 0
Thanks Fra,

1. Yes, it's different when you playing announcement without collect digits. It's not playing if we put the collect digit block. But we already manage that by setting the TServer option Sip-Treatment-Continuous to true. The problem now is that if the agent refuse the call, the caller still hearing the ring tone, very strange systems.
2. We only use  1 codec from the beginning.
3. The call is already ringing at the agent side, so it's not busy.

Thank you very much for your help,

Just our thinking
We just feel very confuse now, since it's a very very very simple easy routing, only route the call to agents. I mean it's very strange if only for this kind of solution we need to setup and configure many thing, it's should be default or at least very easy to implement.
From the installation to the configuration, all of it is a nightmare. I understand it should be our fault because of our not enough knowledge. But we have tried several systems after that, and all of it is just working fine, without a very hard effort.
Really strange, even our customer said that they can develop this simple system themselves, very shame on us!!.
We have done several enterprise solution systems, it's complex too but it's worth it since we need the advance/enterprise features inside it. But genesys is very strange for us, hopefully it's our fault. Since genesys is no.1 contact center software in the world.

Sorry for complaining,

Thanks,

Best Regards,
Hendro

Offline Fra

  • Hero Member
  • *****
  • Posts: 856
  • Karma: -4
Re: caller can't hear ringing tone when call is routing and ringing at the agent
« Reply #10 on: September 10, 2008, 05:01:12 PM »
You are welcome.
What I can say is that I got the same issue with the play&collect digits block.
For the rest, well, I don't know which kind of problems you had in deploying the solution; I just agree that with SIP Server instead of our old boy TServer things are more complicated and what it was a certainty is not anymore :P oh and such a fun reading the logs  ;D

Offline overkill

  • Newbie
  • *
  • Posts: 10
  • Karma: 0
Hi

I am having the exact same problem. If I use a play announcement and collect digits block, the caller cannot hear the ringback tone when the call reaches the agent's phone.
If I remove the collect block and let the call go dirrectly to the agent then the caller can hear the ringing.

I am using sipserver 7.5 and stream manager 7.6.

Any ideas?

Cosmin

Offline Fra

  • Hero Member
  • *****
  • Posts: 856
  • Karma: -4
Does it make any difference if you use a play announcement block followed by a collect digits one rather than a single play&collect?

Offline peters

  • Newbie
  • *
  • Posts: 43
  • Karma: 0
Try to put silence block after the play announcement&collect digits block. I think in our enviroment it helped...

Peter

Offline Timur Karimov

  • Sr. Member
  • ****
  • Posts: 415
  • Karma: 2
Hi all
With my point of view i may recomended check the SIP message on the server and client side. chek for using and reaction by 180 and 100 response code. and rely on it's result try the change coresponding option for the sip servers and soft\hard phones.