Author Topic: Genesys return Error 138  (Read 5541 times)

Offline rapjaw08

  • Newbie
  • *
  • Posts: 24
  • Karma: 0
Genesys return Error 138
« on: July 07, 2010, 05:08:32 AM »
hi guys,

   Do you know what the return error 138 accuring on the Tserver. Is the invldnum stated here is a DN number where you are trying to sent to the Tserver which the Tserver did not recognize.

@01:17:44.9529 [<<] 08 00 00 17 08 02 A3 DA 5A 96 1C 0F 91 A3 0C 02 01 03 02 01 8A 40 04 08 02 81 9C
        TP_AsaiData
        RELEASE_COMPLETE  CRV:a3da
        Facility: RETURN_ERROR
        InvokeId: 3
        Error: 138
        Cause: C_INVLDNUM
@01:17:44.9529 [asai] (processFacilityReturnError)
@01:17:44.9530 [gctmi] request SysRequestRegister deactivated in reqMgr
@01:17:44.9530 [gctmi] TMsg [EventError()] distributing to model
@01:17:44.9530 [gctmi] Address [6204,tRP,sOOS] distributing EventError
@01:17:44.9531 [gctmi] Address [6204,tRP,sOOS] processOutOfService
@01:17:44.9531 [tsgctm] Registrar [6204, l=1, s=0]  RX error response, i=0, c=258
@01:17:44.9531 [gctmi] request SysRequestRegister removed from reqMgr
@01:17:44.9532 [tsgctm] Registrar [6204, l=1, s=0] re-sending attempt 1 of 10 in 1016mS
@01:17:44.9722 [<<] 08 00 00 17 08 02 A3 DB 5A 96 1C 0F 91 A3 0C 02 01 03 02 01 8A 40 04 08 02 81 9C
        TP_AsaiData
        RELEASE_COMPLETE  CRV:a3db
        Facility: RETURN_ERROR
        InvokeId: 3
        Error: 138
        Cause: C_INVLDNUM
@01:17:44.9722 [asai] (processFacilityReturnError)
@01:17:44.9723 [gctmi] request SysRequestRegister deactivated in reqMgr
@01:17:44.9723 [gctmi] TMsg [EventError()] distributing to model
@01:17:44.9723 [gctmi] Address [6223,tRP,sOOS] distributing EventError
@01:17:44.9723 [gctmi] Address [6223,tRP,sOOS] processOutOfService
@01:17:44.9723 [tsgctm] Registrar [6223, l=1, s=0]  RX error response, i=0, c=258
@01:17:44.9724 [gctmi] request SysRequestRegister removed from reqMgr
 

Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 7188
  • Karma: 56330
Re: Genesys return Error 138
« Reply #1 on: July 07, 2010, 05:29:27 AM »
Your PBX is saying that is it an invalid number

Offline rapjaw08

  • Newbie
  • *
  • Posts: 24
  • Karma: 0
Re: Genesys return Error 138
« Reply #2 on: July 07, 2010, 06:31:00 AM »
Thank you for your reply cavagnaro. It seems that the number the tserver is trying to send to the pabx is not defined on the PBX switch. We shall correct this and thank you for your help.

Offline rapjaw08

  • Newbie
  • *
  • Posts: 24
  • Karma: 0
Re: Genesys return Error 138
« Reply #3 on: July 07, 2010, 06:43:14 AM »
Based from the logs sent by the client. there were extensions that are not defined and incorrectly defined on the tserver.

Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 7188
  • Karma: 56330
Re: Genesys return Error 138
« Reply #4 on: July 07, 2010, 09:33:02 AM »
Nice, slap your customer ;)

Offline rapjaw08

  • Newbie
  • *
  • Posts: 24
  • Karma: 0
Re: Genesys return Error 138
« Reply #5 on: July 09, 2010, 05:38:50 AM »
hi Cavagno,

Another logs that was sent to us.
@03:06:13.2655 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258
@03:06:13.3490 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258
@03:06:13.3683 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258
@03:06:13.4254 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258
@03:06:13.5059 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258
@03:06:15.5050 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258
@03:06:17.4103 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258
@03:06:19.0847 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258
@03:06:20.6442 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258
@03:06:22.3245 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258
@03:06:23.9842 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258
@03:06:25.1243 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258
@03:06:27.0048 [tsgctm] Registrar [4971, l=1, s=0]  RX error response, i=0, c=258

based from the logs it seems that Tserver is trying to register this numbers but its incorrectly deifined in the PBX. What you think?






Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 7188
  • Karma: 56330
Re: Genesys return Error 138
« Reply #6 on: July 09, 2010, 05:49:53 AM »
increase the debug level

Offline rapjaw08

  • Newbie
  • *
  • Posts: 24
  • Karma: 0
Re: Genesys return Error 138
« Reply #7 on: July 09, 2010, 06:33:41 AM »
Can you give us more information on the increase debug level. Is this more on the Genesys side? We have checked in the PBX that this number are VDN and the client is trying to register this as ACD queues. Would that make a difference since its incorrectly defined on Genesys.

Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 7188
  • Karma: 56330
Re: Genesys return Error 138
« Reply #8 on: July 09, 2010, 06:48:13 AM »
No TServer configuration:

[log]
verbose=all
all=C:\expresslogs\tserver\tserver


Offline rapjaw08

  • Newbie
  • *
  • Posts: 24
  • Karma: 0
Re: Genesys return Error 138
« Reply #9 on: July 10, 2010, 04:37:35 AM »
Thank you. Aslo I would like to ask what would be the recommended configuration of the switch port  the mapd is connected to the switch port of the Tserver NICS that use to talk to the MAPD. Is the Tserver usually have 4 nics? Is there a doc where i can find the assignment of each nic?

Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 7188
  • Karma: 56330
Re: Genesys return Error 138
« Reply #10 on: July 10, 2010, 05:10:09 AM »
No idea, it will depend on your needs, usually I use 2 NICs, 1 for communication with PBX only and the other for LAN as users and DB, and such, maybe you can determine the use of each by looking at the IP Address of each NIC and comparing with your VLANs mapping