Author Topic: Softphone is happy in VS 2010, but not 2015  (Read 1808 times)

Offline bluelionpiper

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Softphone is happy in VS 2010, but not 2015
« on: April 14, 2016, 01:10:21 AM »
I recently moved into Genesys softphone dev and while I never done any dev work with softphones I come from a heavy .net background.  While I was adding some custom code I noticed that when I tried to run the whole package that an exception would be thrown in one of the Genesys dll's BUT it only happened in Visual Studio 2015.  I can run the code in VS 2010 and 2013.

Here is the exception details:

Microsoft.Practices.Unity.ResolutionFailedException was unhandled
Message: An unhandled exception of type 'Microsoft.Practices.Unity.ResolutionFailedException' occurred in Microsoft.Practices.Unity.dll
Additional information: Resolution of the dependency failed, type = "Genesyslab.Desktop.Infrastructure.IBootstrapController", name = "". Exception message is: The current build operation (build key Build Key[Genesyslab.Desktop.Infrastructure.IBootstrapController, null]) failed: The current type, Genesyslab.Desktop.Infrastructure.IBootstrapController, is an interface and cannot be constructed. Are you missing a type mapping? (Strategy type BuildPlanStrategy, index 3)

Any help would be great!

Offline Kubig

  • Hero Member
  • *****
  • Posts: 2709
  • Karma: 41
Re: Softphone is happy in VS 2010, but not 2015
« Reply #1 on: April 14, 2016, 03:09:35 PM »
Did you check the used .Net version?
Genesys certified professional consultant (GVP, SIP, GIR and Troubleshooting)

Offline bluelionpiper

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Softphone is happy in VS 2010, but not 2015
« Reply #2 on: April 14, 2016, 11:16:46 PM »
Yes.  Right now it's in 3.5.  I tried converting it to 4.0 and seeing if it made VS 2015 happy, but i got the same error.

Offline Konoli34

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: Softphone is happy in VS 2010, but not 2015
« Reply #3 on: August 03, 2022, 05:03:00 PM »
Hi ,

Does anyone know the solution to the error? I Use VS 2022 and Framework 4.5.2
I showed the DLLs but when I try to run I get the error . Is there anyone who can be of assistance? Thank you in advance

An unhandled exception of type 'Microsoft.Practices.Unity.ResolutionFailedException' occurred in Microsoft.Practices.Unity.dll
Resolution of the dependency failed, type = "Genesyslab.Desktop.Infrastructure.IBootstrapController", name = "". Exception message is: The current build operation (build key Build Key[Genesyslab.Desktop.Infrastructure.IBootstrapController, null]) failed: The current type, Genesyslab.Desktop.Infrastructure.IBootstrapController, is an interface and cannot be constructed. Are you missing a type mapping? (Strategy type BuildPlanStrategy, index 3)

Offline hsujdik

  • Sr. Member
  • ****
  • Posts: 498
  • Karma: 23
Re: Softphone is happy in VS 2010, but not 2015
« Reply #4 on: August 03, 2022, 09:37:24 PM »
Did you add the References for Genesyslab.Desktop.Infrastructure.dll (and all other Genesyslab.Desktop.* and Microsoft.* DLLs) on your project?

Offline Konoli34

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: Softphone is happy in VS 2010, but not 2015
« Reply #5 on: August 07, 2022, 09:04:59 PM »
Hello ,

@hsujdik 
 Yes, the dlls you sent are attached, but VS also gives this warning, but the application works. I'm trying to make a VideoCall.


I'm trying to make a VideoCall call with an API link.
With WebView2, but I trigger the Navigate link, but Genesys Worspace Edition does not open in WPF. This took my time, can anyone help with an idea?
Thanks in advance
« Last Edit: August 07, 2022, 09:09:14 PM by Konoli34 »

Offline hsujdik

  • Sr. Member
  • ****
  • Posts: 498
  • Karma: 23
Re: Softphone is happy in VS 2010, but not 2015
« Reply #6 on: August 08, 2022, 07:53:32 AM »
There is a page about how to use the WebView2. Have you seen it?
https://docs.genesys.com/Documentation/IW/latest/Developer/Chromium

Quote
Does anyone know the solution to the error? I Use VS 2022 and Framework 4.5.2
I showed the DLLs but when I try to run I get the error . Is there anyone who can be of assistance? Thank you in advance

In the page I mentioned above, it says that it requires .NET Framework 4.6.2 or higher (and also, WDE 8.5.147.05 or above).

Offline Konoli34

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: Softphone is happy in VS 2010, but not 2015
« Reply #7 on: August 12, 2022, 06:31:10 PM »
Hi hsujdik ,

Thank you very much for your support. I provided Framawork upgrade and editing.
But at this point when i put try cath i get error

This is causing a lot of trouble. WebView2 Tool installation is not installed separately on user computers for a different issue. Do you have any idea for this?
Thank you


Error Message :
System.BadImageFormatException: An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)
   at Microsoft.Web.WebView2.Core.CoreWebView2Environment.CreateCoreWebView2EnvironmentWithOptions(String browserExecutableFolder, String userDataFolder, ICoreWebView2EnvironmentOptions options, ICoreWebView2CreateCoreWebView2EnvironmentCompletedHandler environment_created_handler)
   at Microsoft.Web.WebView2.Core.CoreWebView2Environment.<CreateAsync>d__3.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter`1.GetResult()
   at Genesyslab.Desktop.Modules.ABIntegration.Views.WebView2SampleView.<InitializeAsync>d__14.MoveNext() in