Author Topic: SIP Endpoint not working on Windows 10  (Read 2461 times)

Offline brendanb

  • Newbie
  • *
  • Posts: 32
  • Karma: 0
SIP Endpoint not working on Windows 10
« on: May 04, 2017, 07:28:29 PM »
Hi

I need some advise.

I have installed the latest version of Workspace desktop edition as well as the latest version of the sipendpoint.

The sipendpoint will not work correctly. When you open the application its starts and the voice channel is available but when you make a call after 30 seconds the voice channel goes out of service.

You can see URS trying to target the agent but because the sip endpoint is not initialized correctly it can not route the call to the agent.

I have the correct .net Installed that is in the requirement as well as the Redistributables. There are no errors in the SIP endpoint log and no errors in the Workspace Desktop Edition logs.

Regards

Offline Kubig

  • Hero Member
  • *****
  • Posts: 2625
  • Karma: 41
Re: SIP Endpoint not working on Windows 10
« Reply #1 on: May 04, 2017, 07:30:39 PM »
This seems like network or firewall related issue, not the WDE itself.
Genesys certified professional consultant (GVP, SIP, GIR and Troubleshooting)

Offline brendanb

  • Newbie
  • *
  • Posts: 32
  • Karma: 0
Re: SIP Endpoint not working on Windows 10
« Reply #2 on: May 04, 2017, 09:39:51 PM »
Hi

I have now found the following

It seems the RTP is being blocked.

I see the following messages in the sip server log

13:50:27.959: CGSIPListenerImplementation: Exception on listen socket[708] UDP
13:50:29.959: Sending  [0,UDP] 653 bytes to 10.51.0.84:5060 >>>>>

On both the server and the Windows 10 pc all firewalls has been disabled.

Regards

Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 7131
  • Karma: 56330
Re: SIP Endpoint not working on Windows 10
« Reply #3 on: May 04, 2017, 09:48:10 PM »
I had that problem when my SIP Server had 2 NICs, by forcing SIP Server to use the correct one worked.
Win10 works fine. Something else is your problem.

Offline Nathzn

  • Newbie
  • *
  • Posts: 31
  • Karma: 0
Re: SIP Endpoint not working on Windows 10
« Reply #4 on: May 09, 2017, 03:49:30 PM »
Run a tracert to the sip server from your desktop and then from sip to desktop. This could indicate any connectivity problems.

Offline brendanb

  • Newbie
  • *
  • Posts: 32
  • Karma: 0
Re: SIP Endpoint not working on Windows 10
« Reply #5 on: May 10, 2017, 07:02:31 PM »
Hi

Thank you for the response

The problem is that this is a VM on my laptop. It is not a server some where in a server room

From the SIP endpoint log the sipendpoint starts up fine with no errors there are also no errors in the WDE log.

However when I try to launch the WDE on the server I get the below error in the SIP endpoint log. Not sure if this might be related. According to a similar case logged on Genesys it is a problem with .net update. I do not have the referenced .nets installed

17-05-10 11:21:13.752 [            29] ERROR ndpointCommunication - The IW SIP Endpoint is not available at this time. Exception while communicating with Endpoint:
System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at net.pipe://localhost/SIPPipe2001_192.168.30.139:5060/2001 that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details. ---> System.IO.PipeException: The pipe endpoint 'net.pipe://localhost/SIPPipe2001_192.168.30.139:5060/2001' could not be found on your local machine.
   --- End of inner exception stack trace ---

Server stack trace:
   at System.ServiceModel.Channels.PipeConnectionInitiator.GetPipeName(Uri uri, IPipeTransportFactorySettings transportFactorySettings)
   at System.ServiceModel.Channels.NamedPipeConnectionPoolRegistry.NamedPipeConnectionPool.GetPoolKey(EndpointAddress address, Uri via)
   at System.ServiceModel.Channels.CommunicationPool`2.TakeConnection(EndpointAddress address, Uri via, TimeSpan timeout, TKey& key)
   at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)
   at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
   at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
   at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.CallOpenOnce.System.ServiceModel.Channels.ServiceChannel.ICallOnce.Call(ServiceChannel channel, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannel.CallOnceManager.CallOnce(TimeSpan timeout, CallOnceManager cascade)
   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at
  • :

   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at Genesyslab.Desktop.Modules.SIPEndpointCommunication.Channels.IServiceSIPEndpoint.set_Options(Dictionary`2 value)
   at SIPEndpointSDKApplication.NamedPipeServiceSIPEndpoint.set_Options(Dictionary`2 value)
   at Genesyslab.Desktop.Modules.SIPEndpointCommunication.SIPEndpoint.ConfigureAndStartEndpoint()

I have no problem connecting to the VM from my laptop

Regards


Offline Kubig

  • Hero Member
  • *****
  • Posts: 2625
  • Karma: 41
Re: SIP Endpoint not working on Windows 10
« Reply #6 on: May 10, 2017, 07:34:34 PM »
What say WDE SE logs?
Genesys certified professional consultant (GVP, SIP, GIR and Troubleshooting)

Offline victor

  • Administrator
  • Hero Member
  • *****
  • Posts: 1400
  • Karma: 17
Re: SIP Endpoint not working on Windows 10
« Reply #7 on: May 12, 2017, 10:00:06 AM »
33 seconds is usually for how long traffic is accepted while waiting for INVITE / ESTABLISH in SIP. Most likely one of SIP fields are off or you are receiving the call on inet that has a different IP address than SIP message. Have you tried comparing the two?

Offline brendanb

  • Newbie
  • *
  • Posts: 32
  • Karma: 0
Re: SIP Endpoint not working on Windows 10
« Reply #8 on: September 07, 2017, 08:07:54 PM »
Hi

Apologies I have left this one for a long time.

The problem is still ongoing.

The following has been established.

I use a laptop. What has been found is the following. If disable the wireless network and unplug the network cable you can then open the WDE and it will work. You can now plug in the network cable and it will still work as long as you do not close the WDE.

Remember this is a VM on my laptop that I use for testing.

Regards

Offline Kubig

  • Hero Member
  • *****
  • Posts: 2625
  • Karma: 41
Re: SIP Endpoint not working on Windows 10
« Reply #9 on: September 07, 2017, 09:11:14 PM »
It seems you are using old version of WDE SEP where was a known bug which causes using an incorrect NIC on local PC.
Genesys certified professional consultant (GVP, SIP, GIR and Troubleshooting)

Offline brendanb

  • Newbie
  • *
  • Posts: 32
  • Karma: 0
Re: SIP Endpoint not working on Windows 10
« Reply #10 on: September 08, 2017, 03:02:27 PM »
Hi Kubig

At the time it was the latest WDE available. Thank you I will have a look on the Genesys site if there is a newer version available. Do you maybe know in witch release the bug was fixed.

Regards

Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 7131
  • Karma: 56330
Re: SIP Endpoint not working on Windows 10
« Reply #11 on: September 08, 2017, 10:42:28 PM »
Just install last version

Enviado de meu E6633 usando Tapatalk


Offline brendanb

  • Newbie
  • *
  • Posts: 32
  • Karma: 0
Re: SIP Endpoint not working on Windows 10
« Reply #12 on: September 19, 2017, 03:48:06 AM »
Thank you

Installing the latest version resolved the problem

Regards

Offline chiragkamboj11

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: SIP Endpoint not working on Windows 10
« Reply #13 on: March 21, 2020, 02:42:05 PM »
Hi All,

I am awaking this topic again, We are on the latest version of WDE. WDE does work fine when user work from office but it doesn't work when users work from home using the VPN. This is the exact similar situation initially posted here on this topic that they receive error "Voice Channel Out of Service" ... Could you please advise what else can be checked here.

Offline Kubig

  • Hero Member
  • *****
  • Posts: 2625
  • Karma: 41
Re: SIP Endpoint not working on Windows 10
« Reply #14 on: March 21, 2020, 05:53:22 PM »
Check the communication matrix whether required communication protocols and used ports are allowed
Genesys certified professional consultant (GVP, SIP, GIR and Troubleshooting)