Author Topic: Not receiving events on CS2000  (Read 2946 times)

KBS

  • Guest
Not receiving events on CS2000
« on: November 18, 2009, 01:29:49 AM »
Hopefully someone can provide a little guidance.

Environment (QA):
Nortel CS2000 (hosted IP) with LinkPlexer 6.0
Nortel CRQM (Call Recording Quality Monitoring)
TServer 7.6.009

We're in the process of moving over to the CS2000 from a CS1000. A few months ago, we created 4 phones for testing the Genesys environment, and all worked fine. These four phones were also added to the CRQM system , and are still working as expected.

We recently added 4 additional phones for other testing, and we are having issues with these.
1 - If an agent action is performed on the physical phone (Login, Logout, etc), the events are not sent to the TServer.
2 - If an agent action is performed on a CTI client (such as the agent's client), the TServer reports a timeout for the request, though the request actually occurs (Example: If I were to login via the agent client, the agent client would not change state but the phone would be logged in and in a Not Ready state). If I try to log in a second time, the PBX reports that the phone is already in that state, and the agent client will now correctly report the state.

What may be a contributing factor:
The ACD that these phones are logging in to (8969) is not showing as Monitored in CC Pulse. However, all the phones (Extension and Positions) are showing as monitored.

The CS2000 is being hosted by a switch vendor that does not have any Genesys experience, and I do not have a PBX background, so I am not sure where to tell the vendor to look.

I'll pull some log extracts and post below. If anyone can provide suggestions of where to look, it would be appreciated.

Offline cavagnaro

  • Administrator
  • Hero Member
  • *****
  • Posts: 6759
  • Karma: 56332
Re: Not receiving events on CS2000
« Reply #1 on: November 18, 2009, 02:29:40 AM »
  • Best Answer
  • Are they configured to be monitored by the CTI? Check the deployment guide for Nortel

    Offline CTIgem

    • Sr. Member
    • ****
    • Posts: 273
    • Karma: 0
    Re: Not receiving events on CS2000
    « Reply #2 on: November 18, 2009, 06:20:27 AM »
  • Best Answer
  • Make AST enabled on all the DNs from your switch.

    KBS

    • Guest
    Re: Not receiving events on CS2000
    « Reply #3 on: November 18, 2009, 06:30:32 AM »
  • Best Answer
  • After more digging and scratching, it looks like the issue may be related to the AGTASSN parameter on the ACD. Apparently the TServer for CS2000 attempts to register all the agents based on their association with the ACD queue itself; this parameter causes the agents to register individually.