Author Topic: Interaction Workspace 8.1 No Channel  (Read 4594 times)

Offline PFCCWA

  • Hero Member
  • *****
  • Posts: 584
  • Karma: -7
Interaction Workspace 8.1 No Channel
« on: December 13, 2011, 02:52:41 AM »
Hello,

I am attempting to deploy Interaction Workspace 8.1 in our test lab however have come across this error message when attempting to login using any place:

No Available Channel for this Place

All steps so far seem to have been followed.
There is an extension DN defined for all places.
The IWS application has a connection to sipserver, stat server, configuration server and message server.
The security.disable-rbac configuration option in the interaction-workspace section is set to true.  This I believe means we dont need to define a role with permissions/privileges although I did do this with every option set to allowed.

We dont use media channels such as IM, SMS or email so assumed we would not need a connection to the interaction server (which does not exist anyway).
Even though we would be using it for outbound, there are only ocs and cpd applications for this purpose, no ucs - could this be needed as a connection?
At this moment I think IWS could be looking for these media channels which are not defined?  We are using IWS for inbound and outbound voice only so it is possible that an option somewhere prevents IWS from searching for a non voice media channel.

There is another post which details the same thing but specifies the problem was caused by their version (8.0) not being compatible with SMS/IM/Email so was resolved through using 8.1.

Our set up is:
sip 8.0.400.56
statserver 8.0.000.37
interaction workspace 8.1.101.19
configuration server 8.0.1
message server 8.0.200.04

Thanks,
WA

Offline herve.rochefort

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Interaction Workspace 8.1 No Channel
« Reply #1 on: December 15, 2011, 11:17:12 PM »
I have the very same issue, but did not find yet a solution  ???

Offline herve.rochefort

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Interaction Workspace 8.1 No Channel
« Reply #2 on: December 16, 2011, 10:58:50 PM »
I found my issue.

In IWS logs I could see an error message saying : "No TServer application found for DN:xxx@switchxxx", even if I had a connection to TServer in IWS app object.

The solution was to add Users access group (where my agent is) RX permission on TServer application and Host of TServer as well.

Hope it helps,

Offline gzooby

  • Full Member
  • ***
  • Posts: 141
  • Karma: 0
  • Software Engineer at Telefax S.A.
Re: Interaction Workspace 8.1 No Channel
« Reply #3 on: September 17, 2014, 04:29:34 AM »
Im having the same trouble. Its working on GAD but not in IWS. Checking logs I get the following:

14-09-16 16:25:31.416 [             1] ERROR Workspace.Core.Agent - Not Found Possible Media
14-09-16 16:25:31.419 [             1] ERROR Workspace.Core.Agent - No Initialized media on the place.


Any ideas? My agents are members of SYSTEM

Regards!